Timeout issue with Prism conduct (prism 2.x)

Hello,

We’re facing to issues regarding very long scenario executions. Longer than 2 minutes.
According to the release notes of prism 2.0.0-beta.7, there is a way to configure the request timeout. I suppose that this feature is still available.

  • Is this the timeout for each request (or step) ?
  • or is this the global timeout for the whole scenario/collection execution ?
  • how to configure it ?

Is there a way to extend the timeout for prism execution, please ?
(prism 2.x, and also for the “multi” version onPremise)

Perhaps for you @bear ?

Thanks.

Hi @ntiss,

There are a couple ways to configure timeouts.

For each scenario step, you can configure that by adding a settings object to your scenarios file:

{
  "settings": {
    "http": {
      "timeout": {ms}
    },
  },
  ... rest of scenarios json
}

There is a way to configure the global timeout, you can do it with an environment variable, but it is capped at 4 mins. If that isn’t enough we could cut a new release with that cap removed. Another little secret. Just need to set this environment variable SL_CONDUCTOR_TIMEOUT, and it’s in seconds and restart prism multi.

If you are trying to run all your scenarios in a collection and still are hitting a time out, if you run them one by one, that should help as well.

I don’t think there is a 4-minute cap in prism 2.x, so if you run SL_CONDUCTOR_TIMEOUT=100 prism conduct scenario.json, your scenarios won’t timeout for 100 mins.

Let me know if you have any questions, sorry about the delay!