Reference Utility models in test scenarios is not working

next-release

(Matt) #1

Hi guys,

I am facing an error using the references within the test scenario and I cannot find any way to resolve this.

Everything works fine if I reference the utility component with the same file. The problem seems to be related to references in another file.

Is this a known issue and what can I do to resolve this?

Thanks,

Matt


(Taylor Barnett) #2

Hey Matt, I’m checking this out now.


(Taylor Barnett) #3

Yup, it looks like there’s a bug. We’re starting to look into it right now. Thanks for reporting it.


(Matt) #4

Thanks for looking into this.


(Erik Hansen) #5

@matt - I ran into the same issue last week and reported it to Stoplight. I am hoping it’ll be an easy fix.

Workaround:

  1. Get the “export” link of the file you need to reference https://docs.stoplight.io/platform/export/export
  2. On that scenario step you were creating a reference, change the source type from “This Project” to “External URL” and then paste that export link into the next box to the right. You should then see choices of scenarios, including utilities, show in the box to the right of the URL.

image

The External URL method worked for me, but I would still like to see the “This Project” option fixed.


(Taylor Barnett) #6

Thanks for the workaround, Erik! We are going to work on getting this fixed this week and will hopefully have a fix out early next week.


(Lennart) #7

Thanks @taylor. Do you have an update on the timing for this?


(Taylor Barnett) #8

I believe a fix for this was released in the web app last week. Are you using the desktop app? Or still seeing the issue there? It hasn’t gone out to it, but v4.8.0 is almost ready for release.


(Taylor Barnett) #9

v4.8.0 desktop app was just released:

https://community.stoplight.io/t/changelog-v4-8-0/447/2


(Erik Hansen) #10

Confirmed - this works now. Thanks!


(Lennart) #11

Working in v4.8.0. Thanks!


(Taylor Barnett) #12

Glad to hear this. I’ll wait to make sure it is working for @matt before I close this.