No way to change host binding for Prism running in proxy mode

In the Prism CLI documentation, it says that for running prism in docker, you must bind to to be able to access it from outside the container. The reason for this has to do with docker’s network implementation:

This works fine when running Prism as a mock server, as there is the -h --host argument to specify “” (vs the default However, it seems there is no way to do this if you want to run prism as a proxy server.

Is there a workaround to this or any plans to similarly allow for us to specify host binding for running as proxy? When it runs as, you can’t actually use this from outside docker container.

Alright, so I ended up going into the actual code to see if I could fork and just change the binding, and then I noticed there IS a --host parameter, so now this works for me.


1 Like