Mocking issue - hosted mock instances throw HTTP 400

(Thomas De Groof) #1

Our hosted mocking instance suddenly responds with HTTP 400 on every endpoint.
Response body:

HTTP/0.0 400 Bad Request Connection: close Content-Length: 262 Content-Type: text/html Prism Instance Config at https://next-api.stoplight.io/files.export?projectId=9679&path=mocker.prism.yml&branch=version%2F2.5&deref=all failed to load. The JWT token is expired. You need to acquire a new one by logging in at https://next-api.stoplight.io/session

We did not change anything, so looks like an issue in the backend?
I have an active Stoplight session in the same browser window.

I’ve created a new mock service - same error.

(Taylor Barnett) #2

Hey @thomas.degroof, is the issue still happening for you? It seems to have gotten better. I’m talking with the engineering team to see what might have happened.

(Thomas De Groof) #3

Hi @taylor,

Issue seems to be resolved indeed, everything’s working as before.
Any idea what went wrong?

(Taylor Barnett) #4

Nothing on your end. We had those JWT tokens expire on our end. We recreated them and it worked again, but we are looking into what caused it so it doesn’t happen again in the future.