Git authentication in Studio

Hi all,

How does Stoplight Studio authenticate to the git repo we can use to start a new project ?
I’ve just create a new private Github project on our Actito HQ Github account to validate how to work with Studio, I’ve been able to create a new project (Desktop version) but I’m unable to commit any change (Repo Not Found it says : 37 )
Seems that Studio uses OAuth to connect to my Github project and I’ve granted access to that repo to the Stoplight OAuth :

But in the Developer Tools window I’ve got 404 Not Found on those calls too :

Request URL:
Request URL:

Thank you for your support !

Can anyone light my way on that Studio plugging to Git matter ?
I’d really need to start working with Studio with our github plugged asap …


Hey Marc,

Did you try logging into the Desktop app with Github? That should automatically grant Studio permissions to work with your existing repos. Then input the git repos URL to start working with an existing repo.

Just tried to disconnect from our actito-io account and reconnected with my own MarcLevisse github account
I still get an error :

I tried to delete the project, log into Studio with my github account and then re-checkout the project ( and I now get this message after checkout :

After that I still have the 404 error whenever I test a commit/push

Here is the .git/config file in the created project (created by checkout within Studio) :

repositoryformatversion = 0
filemode = false
bare = false
logallrefupdates = true
symlinks = false
ignorecase = true

[remote "origin"]
	fetch = +refs/heads/*:refs/remotes/origin/*
	url =
	corsProxy =

There’s a bit more Git funcitonality exposed in the web app. Try logging in at with your Github account. Then select your account name in the top-right menu.

Then select External Account to check your Git integration or set it up. If it says connected like the image below then I would check your permissions in your organizations Github repository. You may not have the proper permissions to make commits or clone repos.

For anyone else running into authentication issues with a Github organization, be sure to check for any app access restrictions within your Github org:

We have a full documentation article available on this issue here as well: