Can't run cli stoplight command

I have installed it
npm i -g @ stoplight / cli
but can’t use stoplight commands

image

additional information :
os - linux opensuse

1 Like

i run
node /usr/lib/node_modules/@stoplight/cli/bin/stoplight.js publish --token thisimytoken --url https://stoplight.io/api

success

Unfortunately I don’t have a solution, but I have been wrestling with this issue for over two hours. I’m trying to install this in a docker container for a GitHub action, and none of the solutions online seem to work.

I’ve tried these proposed solutions

  • Creating symlink with ln -s /usr/bin/nodejs /usr/bin/node
  • Installing nodejs-legacy instead

I’ve also posted the question to stackoverflow

If I find a fix, I’ll repost here.

Hello @addin and @tylerscottnielsen, we are very thankful for your feedback on this feature.

The engineering team at Stoplight reviewed the information you provided and added a fix to the cli as described here.

You should be able to use the cli using version 3.0.4.

Let me know if this resolves the issue for you!